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This document is to be used to train technicians and end-users in supporting customers in using the 

Custom Tables feature of Act!. It includes a description of the new feature, when it will be available, 

which customers will be able to use it, support boundaries for technicians, and instructions on how 

to set up Custom Tables and use them. 

 

Prerequisites 
 

In order to complete the exercises successfully, the each technician will require access to the 

Custom Tables feature. Therefore they will require ONE of the following environments: 

• Act! Premium v20 for Web installed locally and the Custom Tables beta version installed. 

• Act! Premium v20.1 for Web installed locally. 

 
 

Exercises 
 

Throughout the training material consistent and relevant examples of Custom Tables will be 

showcased. Specifically these examples will focus on creating Custom Tables to record Support 

Contracts and Support Tickets. It is recommended that as go through the workbook you follow 

these examples thoroughly and perform the same steps to create them in your own database. The 

exercises at the end of each section will simply summarise the steps already covered.  

 
 
 
 
 
 
 
 
 
 
 
 
 

Summary of Custom Tables  
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One of the more common feature requests in Act! is the ability to create new customized sections of 

the program. The existing sections in the navigation stackbar are obviously extremely useful, but 

customers also want a way to create their own sections, and have the information in these link to 

existing entities such as the Contacts section or Companies section. This higher level of 

customization has been missing from Act! to date, but as of version 20.1 it has been added in under 

the feature called Custom Tables. 

Using this feature the customer will be able to easily create as many additional sections as they like, 

each with their own tables, fields and layouts, and all without requiring any specialist development 

knowledge or skills. Some examples of this in use could be an estate agent that creates a table of 

the various properties they are selling with as many different customized fields as they want, then 

they could link these properties to any contacts that are interested in them, or a support team could 

create sections for customer contracts and support tickets, once again easily linking these with the 

individual contact records they relate to. 

It is possible to add a Custom Table as a new option in the navigation stackbar, as well as adding 

the information as tabs in the Contacts, Groups, Companies and Opportunities sections. Custom 

Tables can be used within both the desktop and web versions of Act!. 

 

Why Custom Tables? 

This initiative came about for number of reasons: 

1. Our customers were hitting limitations with the current Act! product, when they needed to 

manage data outside of what the existing Act! entities deal with. 

2. We commonly lose customers whose businesses have grown or changed, where they need a 

more flexible and bespoke solution from their CRM. 

3. Frequently customers would try to customize areas such as Contacts or Opportunities to 

store data which these aren’t really designed to manage. This would lead to some interesting 

support calls as customers realized the limitations of working this way. 

4. Custom tables have always been possible via our SDK, but the requirement for developer 

knowledge puts this out of the reach of most customers and ACCs. 

5. There have also been 3rd party custom table solutions available for many years, but 

customers don’t always trust (or want to pay more for) a solution which we can’t support 

them with. 
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6. Customers and ACCs have long desired a custom tables solution with a simple UI, which is 

supported by us! 

 

What Problem does this Solve? 

Custom Tables let customers make Act! truly specific to their industry or work practices. They can 

create new tables integrated into their existing Act! data, allowing them to manage different types of 

data such as: 

• Projects 

• Contracts 

• Support Tickets 

• Property 

• Vehicles 

• Software licenses 

• Loans 

Our sales team are commonly asked whether Act! can store data in areas such as these, and now 

the answer in most cases is yes! Using Custom Tables, customers and ACCs can now build very 

tailored vertical solutions, keeping track of all of the data they need to manage in their business in 

one place. 

 

What Industries does this Work For? 

Whilst there are no limits to the custom tables and fields you can create, we’ll be introducing 10 – 12 

‘industry templates’ with Act! v20.1, allowing customers in specific industries to get a fully 

customized database within just a few minutes. A list of these will be finalized soon, but is likely to 

include the following industries: 

• Support (managing contracts and tickets) 

• Insurance (managing policies and claims) 

• Real Estate (managing property, contracts, tenants, landlords etc.) 
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• Mortgage (managing mortgages…) 

• Wealth Management (managing loans, investments, policies etc.) 

 

When will this feature become available? 

Custom Tables is a new feature that will be added into Act! v20.1 expected currently at the end of 

February. It will form the major focus of that release. 

 

Managing Tables 
 

NOTE: Only Administrators and Managers have access to Manage Custom Tables shown below. 

Other users simply do not get the option. 

Once you have either installed the beta version (if using Act! v20), or else you have installed Act! 

v20.1, a new Custom Tables menu will be displayed within the program: 

 

To begin working with this feature, you will first need to create a custom table. 

NOTE: At the end of the creation process or when editing an existing table the database will lock. It 

is therefore best practice to make sure all other users log out of the database when working with 

Custom Tables. 

 

Creating a Table 

Click Custom Tables > Manage Custom Tables. 



 
 
 
 
 
 

8  Back to Top 
 

 

Under Table Management, click Create Table. 

 

Enter a Table Name which is the name the table will be given within SQL. Optionally, you may enter 

a different Display Name which is the name that will actually be displayed within the Act! program. 

Note that the Display Name can be changed later, however the Table Name cannot. 

NOTE: As the Table Name will be listed in SQL it follows those naming conventions, i.e. it cannot 

contain any spaces, it must be less than 32 characters etc. otherwise you will receive an error 

message when you try to proceed. The Display Name however does not need to follow these 

conventions. 
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You can also choose a Logo for the custom table at this point which will be displayed next to the 

table name in the navigation bar once the table has been created. To make use of this, you will need 

to browse to your own appropriate image file. 

 

Under Additional Settings, select all of the areas where you would like the custom table to display. 

These options can be amended later if ever needed. 

 

Click Next. 

Select the Act! entities the table will link to. In most cases Contacts and Companies are sufficient, 

but note that this selection CANNOT be changed later.  

NOTE: When choosing your entities, you must make sure these match the Additional Settings that 

you chose in the screenshot above. For example, if you had ticked Show as a Group tab above, 

then you would need to make sure so select Link to Groups in the screenshot below. 
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Click Next to confirm, and Next again to create the table. 

NOTE: As advised in the final screen, the database will be locked upon the creation of the table. 
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The table can take a few minutes to create, and as advised it is best not to interrupt this process. 
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Once the table has been completed successfully, you will receive a confirmation message. Click 

Finish to continue. 
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Setting Default Columns 

After creating the new table, a prompt asking to set default columns will be display.  

 

Here you can select the columns that will be displayed to all users. This list can be accessed again 

by clicking Edit Default Columns on the main Manage Custom Tables dialog.  
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If you choose to edit the columns you will see the following screen. 
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Whenever a new table is created it comes with the standard fields that you can see in the 

screenshot above. These fields only exist in the Custom Tables section of Act! (ie. if you navigate to 

Tools > Define Fields you will not see the Custom Tables fields listed). 

It is possible to create your own custom fields as well use fields from other entities in the Act! 

program (Contacts, Companies, Groups and Opportunities). Creating fields will be discussed later in 

the training. 

To define the columns, firstly you need to select the Record Type that you wish to add. 
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As you can see, it is possible to not only add your own Custom Table fields, but you can also pull 

information from the other Act! entities as well. You can use fields from multiple entities if you wish. 

Once you have chosen the Record Type, simply click the fields you wish to show and use the Arrow 

icons to move them across. In this example we have added some custom table fields (we will cover 

how to create custom fields later in the training) as well as the Contact field from the Contact section 

as well. 
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Click Apply to finish this process. 

Now that the Custom Table has been created and the default columns have been added, it will 

already appear within the areas of the program you chose in the Additional Settings as discussed 

above. For example, if you selected the Show in Navbar option, you will now be able to select your 

Custom Table from the navigation stackbar. 



 
 
 
 
 
 

18  Back to Top 
 

 

Also if you chose any of the tab based Additional Options such as Show in Contact tab, you will 

now see the Custom Table has been added as a tab in the areas that you have selected. 

 

Clicking on your new Custom Table in the stackbar or clicking any tabs you have added will now 

show the default columns that you have set. 

 

If this step was not taken, the Custom Table will appear blank. 
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Editing Tables 

Once you have created a Custom Table, you may wish to edit it or even delete it. We will discuss 

how to perform edits, which elements within the table can be edited, and how to delete tables 

below. 

Click Custom Tables > Manage Custom Tables, then from the Load Table dropdown, select an 

existing table. 
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Click Edit Table. 
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As you can see from the screenshot below, you are able to edit the Display Name, the Logo, and 

the Additional Settings. 

 

Remember though that the availability of the Additional Settings is very much linked to the next 

screen which shows the linked entities. The reason the Show as a Group tab and Show as an 

Opportunity tab are unavailable in the example above is because we did not select Groups or 

Opportunities as linked entities when we created the Custom Table. You can see this by going to 

the next screen. 
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As mentioned earlier in the training, when you initially create your Custom Table and choose the 

linked entities, these cannot later be edited.  

To save any changes you have made, click Next until you reach the end of the wizard, then click 

Finish. 

 

Deleting Tables 

It is possible to delete any Custom Tables you have made. Deleting a Custom Table will delete it 

from all areas of the program (i.e. it will be removed from the navigation stackbar and if it has been 

added as tabs in any Act! entities these tabs will be removed as well) and any information you have 

saved within the Custom Table will be deleted as well. 

To delete a Custom Table, click Custom Tables > Manage Custom Tables, then from the Load 

Table dropdown, select an existing table 
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Click Delete Table. 
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Click Yes to the following message. 

 

The database will Lock as the Custom Table is deleted. This process can take a few minutes. Once 

completed, the following message will display. 

 

 

Exercise 

Create a Custom Table called Support Contracts. Make sure it can be viewed in the navbar, as 

well as the Contacts and Companies sections. Link the table to the Contacts and Companies 

sections. 
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Managing Fields 
 

Once you have created your custom table, it is possible to create additional fields to display within 

the table. As an example, if you have created a Custom Table for Support Contracts, you may 

require fields such as Contract Level, Contract Start Date, Contract End Date etc. We will look at the 

process of adding and amending custom fields now. 

 

Creating Fields 

To begin, click Custom Tables > Manage Custom Tables, then select your table from the Load 

Table dropdown. 

Under Field Management on the left, click Create Field. 

 

Enter a Field Name, and select a Field Type to match the data you wish to store. These types are 

the same as those found under the normal Define Fields section of Act!. 

NOTE: Unlike the Define Fields section, once you have chosen a Field Type and created the field, 

this cannot be changed later. 
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Check any Additional Settings that apply. The options available in the Additional Settings are 

dependent on the Field Type you have selected, exactly the same as the normal Define Fields 

section of Act!. Once you have chosen the appropriate Additional Settings, click Next. 
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Further options in the creation wizard will once again depend on the Field Type that has been 

chosen. For example, if you have chosen a Character field, the next screen will look like this: 
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As you can see, you have options to specify a Default Value for the field if required, and set the 

Field Length. Ignore the Sequential Field Settings for now as this will be covered later. 

Alternatively, if you have chosen a Date field, the next screen you see will be the final confirmation 

screen. 
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Click Next then Finish. 
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Editing Fields 

Once you have created custom fields, you can perform some edits on them, much the same as with 

the normal Define Fields section of Act!.  

NOTE: You can only edit custom fields that you have created. The standard default fields that are 

always created with each new table cannot be edited. 

To edit a custom field, click Custom Tables > Manage Custom Tables, then select a table from 

the Load Table dropdown. 

Click the field you would like to edit. 

Click Edit Field on the left to edit the field’s properties. 
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As mentioned previously you cannot amend the Field Type, however the rest of the options you 

have selected such as the Field Name, the Additional Settings or the Default Value and Field Length 

can all be successfully amended.  

 

Deleting Fields 

As well as the ability to edit custom fields, you can also delete them should you need to. As you 

would expect, deleting a field in this manner will delete all of the information within that field. 

NOTE: You can only delete custom fields that you have created. The standard default fields that 

are always created with each new table cannot be deleted. If you attempt to delete these fields, you 

will receive the below error: 
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To delete a custom field, click Custom Tables > Manage Custom Tables, then select a table from 

the Load Table dropdown. 

Click the field you would like to delete. 

Click Delete Field to remove the field from your database. 

 

You will receive a warning advising that the database will be locked and the selected filed deleted. 

 

Click Yes to proceed. This can take a few seconds to complete successfully at which point you will 

receive the following message. 
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Click OK. 

 

Exercise 

Create 2 new fields for your Support Contracts Custom Table. Call these fields Star Date and End 

Date, and make sure they are set as Date fields. 

Amend the Default Columns (see the Managing Tables section) to show the Contact name, the 

Start Date, and the End Date. 

 

 

 

 

 

 

Creating Layouts  
 

After you have created a Custom Table, in order to actually make use of it you must create a layout. 

This layout will be used if you have added the Custom Table to the navigation bar, and also if you 

have added it as a tab. it is possible to create multiple layouts if you wish. 

As the process for creating a layout differs slightly between the desktop and web version of Act!, we 

will cover each process separately below. 
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Creating a Layout (Desktop Client) 

To begin, click Custom Tables > Manage Custom Tables, then select a table from the Load Table 

dropdown. 

Under Additional Customization on the left, click Design Layouts. 

 

Click Create Layout. 
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At the top of the Design Layout view, enter a Layout Name. 

 

By default there may already be certain fields showing in the Design Layout view. When creating 

your table, towards the end of the wizard you were asked to select entities to link the table to. In 

order to correctly link your Custom Tables to an Act! record (such as a Contact), you must provide a 

linking field. In the example we have been using throughout this training, we could create Support 

Contract records in our Custom table, then link these to individual Contact records in Act!.  

 In our earlier example, we chose to link our Support Contracts Custom Table to the Contacts and 

Companies sections of Act!. Therefore, when we go to create a layout, the program has already 

added the Contact field and Company field for us to be used as linking fields. 
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The fields show values to demonstrate the information that will be displayed once you finish creating 

the layout. 

To add your custom fields, click and drag them from the Properties Window over to the Design 

Layout view (if you cannot see the Properties Window then click on the Show Properties Window 

next to the Layout Name field).  
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The Layout Designer is designed to be quite intuitive. As you drag fields across, the Layout Designer 

will highlight in pale blue (as can be seen in the screenshot above) where the field will be placed 

when you release the mouse button. In this way you can easily drag fields into a list, you can add 

them as columns, you can place new fields between existing ones on your layout or a combination 

of the above until you are happy with the design. If you want to remove a field, you can click on it 

then press the delete key on your keyboard. 

As a quick example of just dragging and dropping the various fields, we have created 2 custom 

fields called Start Date and End Date, then dragged these onto the layout so they appear side by 

side beneath the Contacts and Companies fields (remember these are our linking fields). 

 

Click OK to save the layout. 
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Note that only the default layout will be displayed to users. If multiple layouts are created, select a 

layout and click Set as default to display this for all users. 

 

 

Creating a Layout (Web Client) 

As previously mentioned, the process for creating a layout within the web client is different to the 

desktop version so we will cover this below. 

Begin by clicking Custom Tables > Manage Custom Tables. Note that this is the ONLY option 

available in the Custom Tables menu in the web version of Act!. 

 

Select a table from the Load Table dropdown. 
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Under Additional Customization, click Design Layouts. 
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Click Download Layout Editor. 

 

A file will download named CustomTables_LayoutEditor.zip. Unzip the file to a new folder, and run 

the CustomTables_LayoutDesigner.exe. 

NOTE: You MUST unzip the file to a new folder. If you just double-click the zip file and try running 

the .exe file, it will not work. 
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Enter the Web Service address, along with the Database name, User name and Password. The 

Web Service Address can be found from Tools > Preference > Email, then selecting the click here 

link under E-mail Integration. 
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Click Next, then select a Custom Table. 
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Click Next again. The Design Layout process now works just as it does from the Act! desktop 

client. 

After creating or editing a layout, click Save Layout under the Layout Management screen to pass 

these changes to the web client. 
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Keep the downloaded CustomTables_LayoutDesigner.exe file if you wish to quickly create or edit 

layout files in the future. 

 

Exercise 

Create a layout for your Support Contracts Custom Table. Make sure to add the Contacts, 

Companies, Start Date and End Date fields. Set the layout as Default. 

Create a second layout using the Web version of Act!. 
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Working with Custom Tables 
 

Now that we have created a Custom Table, set the default columns and created a Layout, we can 

now begin to actually use the Custom Table. By showing an example of this in use we will begin to 

see how powerful this new feature really is. 

 

Adding Values 

To begin, we will enter a contact record and open up our Support Contracts tab, then we need to 

click the Add button. Note that an additional custom field called Serial Number has been created, 

added to our columns, and added to the layout as well. 

 

After clicking Add this is where we can see the Layout that we created earlier and this allows us to 

actually add values into our Custom Table. 
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In the example above, the Contacts and Companies fields were already completed; they were 

pulled automatically from the Contact record. This will happen provided that the Contact record is 

linked to a Company, otherwise only the Contact field will automatically populate. 

Once we have entered appropriate values we can click OK which will add this line to the Support 

Contracts tab for this individual Contact record. 
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We can now fill in this tab for other Contact records too. 

 

If we now take a look at the Company record for CH TechONE (remember when we created this 

Custom Table we chose to show it as a tab in Companies and chose to link the Companies entity 

to it), we can see that both contracts from the above screenshots are listed in that tab. 
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Finally, if we go to the Support Contracts section in the navigation stackbar (remember that when 

creating the Custom Table we made sure to show it in the stackbar) we can see all of the values we 

have added in here as well. 

 

This works much like the History List in Act! in that it lists all of the Support Contracts that have 

been added across the whole database. The list can be Sorted by clicking on any of the column 

headers. 

 

Custom Tables Functionality 

When using Custom Tables as a tab or as an option in the navigation stackbar, there are a number 

of buttons that run along the top of the view. 
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We will discuss the functionality of the simple buttons now, then cover the more complex buttons 

further below. 

 This button refreshes the Custom Tables view. You may need to use this if 

you add values into Contact tabs and they don’t immediately appear. 

 This button allows you to add values into your Custom Table. After clicking 

Add, you will be presented with the Layout you created earlier allowing you 

to add the required values. 

 This button allows you to delete records from your Custom Table. After 

clicking the button you will be prompted to confirm that you wish to delete 

the selected records. 

This button allows you to customize the columns you wish to display within 

your Custom Table. 

 This button allows you to export the listed data as either an Excel file or a 

.CSV file. 

 This button allows you to print the listed data. 

 

This dropdown allows you to narrow the listed data by running a query 

(think of this like a saved lookup). We will look at creating queries later in 

the training. 

 

Group 
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The Group icon allows you to quickly and easily group together similar entries in your Custom 

Table. Clicking the icon switches this function on. 

 

To group your records together, simply drag and drop one of your column headers into the new 

space highlighted above. In this case we will group by Start Date. 

 

As you can see, each record is now grouped by their Start Date. Clicking on the Arrow to the left of 

the start dates expands group and you can then see the individual records within it as per the 

bottom record on the screenshot.  

If you want to add further filters to the group, you can drag and drop other column headers into the 

group section as well. So if we imagine we want to group by Start Date then by Serial Number, we 

can drag and drop the Serial Number column next to Start Date. 
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The results are as follows. 

 

As you can see, two filters are showing in the group. Once you click the Arrow to expand results for 

the first filter (Start Date) you then get another Arrow to expand for the second filter (Serial Number). 

NOTE: If you click the Group icon to switch it off, you will lose any groups you have set up. 

Switching the feature back on will mean you have to create your group again. 

 

Quick Filter 

Turning on the Quick Filter feature allows you to type in values to narrow down your Custom Table 

records. You can think of this as similar to the Look For feature in the Contacts section, except that 

Quick Filter will search multiple columns at the same idea. For example, if we switch the feature on 

and perform a search for 2018 we get the following results. 
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As you can see, performing this search has found results in multiple columns and highlights the 

results found. 

Quick Filter will only show records that match the search performed. So for example, if we search 

just for Steven we will get far fewer results. 

 

Clicking the Clear button will return you to your full list. 

 

Exercise 

Create a new field called Serial Number for your Support Contracts Custom Table. Make sure this 

is a Character field. 

Add values into your Custom Table against 5 different Contacts. At least 2 of these should have the 

same Start Date. 

Practice using the Group and Quick Filter functions. 
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Relating Custom Tables and Fields 
 

Now that we have covered the basic functionality of Custom Tables, we are going to progress into 

the more complex features available. One such feature is the ability to relate Custom Tables and 

Fields to one another. The idea is that you can create multiple Custom Tables and have the records 

within them associate with each other. 

For example, if you work in a support environment you could create a Custom Table to store your 

customers Support Contracts. Then you could create a second Custom Table that contains Support 

Tickets from your customers. Finally, you could relate these tables together so that all of the 

Support Tickets for an individual appears underneath their Support Contract. 

In this example, the Support Tickets would be in the child table, and Support Contracts exist in the 

parent table. We will perform an example of how this works below. 

NOTE: For this example, we have created a very simple second Custom Table called Support 

Tickets. It has the custom fields Date and Notes. 

 

Relating Custom Tables 

To begin creating a relationship, click Custom Tables > Manage Custom Tables, then from the 

Load Table dropdown, select the table which will be the CHILD table. 
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Click Create Field, and create a new character field in this table with at least 36 characters. This will 

be used to link the child and parent tables together. It is usually best to give this field the same 

name as the parent table. 
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Once the field has been created, following the steps we have discussed earlier in the training, add 

this newly created field to the CHILD table layout. This is a very important step and must not be 

skipped. 

Once completed, ensure the CHILD table is still selected in the Load Table dropdown. Then under 

Table Management, click Manage Parent Tables. 
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Click Add Parent Link. 
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Select the PARENT Table from the dropdown and click Next. 

 

Select the Link Field you just created, and click Next until the end of the wizard. You can then click 

Finish to create the relationship. 
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Once the relationship is created, a new field will be available in the layout editor for the PARENT 

table. This appears in the standard format ChildTableName Records (so in our example this would 

be SupportTickets Records). Once added to the layout, this will display a list of all linked child 

records. We will go through an example of how this works in practice below. 

 

Working with Related Tables 

In the example above we looked at how to relate two Custom Tables together, Support Contracts 

(the PARENT table) and Support Tickets (the CHILD table). Now that this relationship is in place, 

we need to see how this relationship actually works in the program. 

As an example, let’s take a look at a Contact record who has a Support Contract. 

 

If we now double-click on the Support Contract record, it will open up like so. 
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Notice that there is now a large section for the linked Support Tickets table. However as it stands 

there are no records listed. This is because the individual contact we are looking at does not have 

any records in the Support Tickets Custom Table. Let’s look at adding some records now. 

To do this, we’re going to click on the Support Tickets tab in the Contact record, then click the Add 

button. 
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As you can see in the example below, we are using a very simple layout for this Custom Table. We 

have the Date field, the Notes field, and crucially, we also have the Support Contracts field.  

Remember when we linked the tables together we had to create a new field for the child table. This 

field needed to have the same name as the parent table, and then needed to be added to the layout. 

This was a crucial step as it allows us to link the records now. 

We will complete the Date and Notes fields with some dummy information. 

 

Now in order to link this Support Ticket to the Support Contract, click on the ellipsis on the end of 

the Support Contracts field. 
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This will show you Support Contract records linked to the same Contact. Whilst you can change 

the dropdown to find other Support Contracts from other Act! records if necessary, in the majority of 

cases this should not be necessary. 

 

Once you click OK you will be able to see the linked record listed. 
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Click OK again to complete the process. 

If we now go back to the Support Contracts tab on the Contact record, and then double-click on it 

to open it up fully, we will now see the Support Ticket is listed. 
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If you then double-click on the Support Ticket itself you can also open that up fully to view or even 

edit the details. 
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Exercise 

Create a new Custom Table called Support Tickets. Make sure it has 2 custom fields called Date 

and Notes. Create a Layout for the Custom Table and setup the Default Columns. 

Create a Relationship between your 2 Custom Tables. Ensure the Support Contracts Custom 

Table is the PARENT and the Support Tickets Custom Table is the CHILD. 

Add new Support Tickets against the 5 Contacts you worked with previously. Make sure you add 

several Support Tickets against one Contact record. 

Using the Support Contracts option in the Navbar, open your Support Contracts and see if the 

linked Support Tickets appear. 
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Managing and Sending Templates  
 

When creating Custom Tables, all of the data added exists only within that area of the program. For 

instance, if you create any fields for your Custom Tables you cannot see these in the standard Tools 

> Define Fields section of Act!, nor can you add them to the standard 

Contact/Company/Group/Opportunity layout, you must add them to your Custom Tables layouts 

only. Because of this, you are not able to mail merge these fields using the normal methods through 

the Write menu. 

To overcome this, the Custom Tables feature has its own ability to create and send mail merge 

templates that do make use of the data stored in custom fields. In this section of the training we will 

see how to both create a template and use it in a mail merge. 

NOTE: This functionality currently works in the Act! desktop client only. 

 

Creating Templates 

To begin, click Custom Tables > Manage Templates. This may take a few minutes to set up the 

designer if this is the first time you have used it. 

You will be prompted to open an existing template. Again if this is the first time you have used the 

editor then you will not have any templates available. In this case click Cancel. 
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The template editor has been designed to look as much like Microsoft Word as possible in order to 

make sure new users find it easy to work with. However it is important to note that this editor is 

completely bespoke and comes with the Custom Templates feature, it does not require any Office 

integration in order to work. 
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You can create your mail merge template just as you would normally, entering static text and images 

as needed. if you wish to add a mail merge field, click the Insert Mail Merge Field button.  

 

 

Select the required table from the Record Type dropdown to view all fields in that table. As can be 

seen in the screenshot above, you can pull information from the Contact section, the Opportunities 
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section, and any Custom Tables that you have created (in this case Support Contracts and 

Support Tickets). 

Select the required field and press Insert to add it to the document, exactly as you will have seen 

when editing normal mail merge templates. 

By adding text, images and mail merge fields you can now fully complete your template. A simple 

example is given below, note the two mail merge fields that have been added, one from the 

Contacts section, another from the Support Tickets Custom Table. 

 

Once the template is ready, click File > Save and give the template a meaningful name. 

Close the Template Editor. 

 

Individual Merge to Email/Word 

Now that you have created a template, you will want to use it to perform a mail merge. Mail merges 

can be performed using either Microsoft Word or Microsoft Outlook, and they can be performed 

using one record or using multiple records. We will go through examples of this below. 
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To perform a mail merge, right click on a Custom Table record that you wish to merge and choose 

Merge To. You can do this wherever the Custom Table record appears (so for example, you could 

do this within a Contact tab, or when using a Custom Table in your navigation stackbar). 

 

If we choose Email, the next prompt is to choose the template that we wish to use. 
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Once you choose your template and click Open, Outlook will then launch an email using the 

selected template. 

NOTE: You may get the below warning in Outlook, make sure to click Allow to this message. 

 

An example of a merged email can be seen below. 
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As you can see, the mail merge fields have been completed correctly. As this Custom table is linked 

to the Contact section of Act!, the mail merge process has also been able to pull through the email 

address of the linked Contact into the To field. 

Choosing the option to mail merge to Word is a very similar process. Once again right click on a 

Custom Table record that you wish to merge and choose Merge To. 
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If we choose the option for Word this time, then once again we are asked to select a template that 

we wish to use. 
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Once you choose your template and click Open, Word will then launch using the selected template. 
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Merging Multiple records to Email/Word 

As well as merging to individual records using the Custom Tables feature, you can also merge 

multiple records at the same time. We will demonstrate merging to multiple records using Email and 

Word below. 

Firstly, you must highlight all of the records that you want to merge. This is typically done by using 

the Custom Table option in the navigation stackbar so that you have a list of records that you can 

merge. 

 

To highlight the records, use the CTRL or SHIFT keys on your keyboard (you can of course create a 

Group or use the Quick Filter to help narrow down your list). Once you have the desired records 

highlighted, right click on them and choose the option Merge To. 

 

If we choose the option for Email, we will then be prompted to choose the template as previously, 

but after that we will see a new screen. 
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Enter a Subject for the mail merge. 

As part of this process, an individual email will be sent to each of the Contacts separately, exactly 

the same as with the normal Act! Mail merge feature. The options you can see on the screen above 

are if you also want to copy in additional email addresses (such as the account manager for 

example). 

 Once you click Next, Outlook will then send out all of the emails automatically. 

Once the process is complete you will receive a confirmation message. 
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If instead of choosing to merge as an Email we choose the option for Word instead, we will once 

again be prompted to choose a template. As soon as you have chosen a template however, an 

instance of Word will then open for each Record highlighted. So for example, if I have three 

records highlighted and perform the merge to Word, three documents will be opened. 
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Exercise 

Create a simple Template that advises customers their Support Contract is about to expire. Make 

sure to include the End Date from your Support Contracts Custom Table as a mail merge field. 

Test sending your template to individual contacts via email and Word, then test sending your 

template to multiple contacts via email and Word. 
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Importing Data  
 

As with many other parts of Act!, it is possible to import data from a Microsoft Excel spreadsheet or 

CSV file directly into your Custom Tables. This can obviously save the customer a lot of time, 

particularly when they first start using Act!. The recommended method of using this feature is to 

import information into your Custom Tables for existing records 

(Contacts/Groups/Companies/Opportunities) in Act!. So for example, if you wanted to import a list of 

old Support Tickets for your Contacts into your Custom Table, you would need to already have 

those Contact records created in Act!. 

In the example below, we will examine how to import a spreadsheet and include information on 

duplicate checking. As always, we would strongly recommend backing up a database before 

performing an import. 

NOTE: This functionality currently works in the Act! desktop client only. 

The example below will use the following simple spreadsheet. 

 

 

To begin, click Custom Tables > Data Import > Import From Spreadsheet. 
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You will be prompted to select the spreadsheet file that you wish to import. Click the ellipsis icon, 

browse to your spreadsheet and click Next. 
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Select the table from the dropdown where you want to import the records to. Click Next. 
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If the spreadsheet contains fields which can be used to link the records to an Act! entity such as 

Contacts, Groups, Companies or Opportunities, select and map them. In this example we want to 

import Support Tickets and have them match against existing Contact records which has been 

highlighted below, but note too the other entity options at the bottom of the window. 
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If no mappings are defined, the records will be imported under the currently logged in user’s 

contact record. This is why it is important to make sure the Contact records you wish to import 

information against are already created in the database (as mentioned at the start of this section of 

the training). Ideally you will want to map several Act! fields at this point to make sure that the 

imported data links to the correct existing records. In this example we will only map one field, 

Contact, and see if there are any problems. 

Click Next. 

Map the Import Field fields to the Custom Table Fields. If you wish to duplicate check the records 

that will be imported, you can enable duplicate checking on the required fields by checking the 

Duplicate Check column. Click Next once fields you wish to import are mapped.  
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In the example below, we have a Contact column that is not mapped at this stage. This is because 

our Custom Table itself does not have a Contact field. This field has only been included on the 

spreadsheet to make sure that the records link to the correct Contacts once they have been 

imported (see above screenshot). 

 

From the dropdown select the action that will be taken if a duplicate is found.  
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Press Next twice to import the records in the database. 
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Once the import completes, you will see the following screen. 
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Click Next to see the final confirmation screen, then click Finish. 

The records will now have been imported into your Custom Table. As we can see below, the new 

records have been added to the Support Tickets Custom Table. 
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Earlier in this section we mentioned that when importing the spreadsheet, we wanted to import the 

records against existing contacts in Act!. As you can see in the first column, this has occurred 

successfully. However if you recall, we only chose one field to base this mapping on, the Contact 

field and this could cause us problems. 

If we open up one of Jonathan Jenkins records, note the Contacts listed at the top of the record. 
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We have two Contact records in Act! that are called Jonathan Jenkins, and as we only matched on 

that one field, BOTH contacts have been linked to this Support Ticket record. That is why it is 

recommended to match on as many fields as possible. 

 

Exercise 

Import the spreadsheet entitled Tickets Import into the Support Tickets Custom Table in your 

database. 

NOTE: You will want to replace the contact names in the spreadsheet with names of the contacts 

you have been working on in your database. 
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Migrating Data 
 

Instead of importing data in, it may be the case that customers have been recording information in 

normal Act! fields that they want to move to a custom table. Perhaps for example the customer has 

created additional fields to record the customer’s serial number, but now they have a dedicated 

table for it and they wish to transfer the data to the Custom Table instead. This section will examine 

how to do this. 

In the examples below, we will be moving data from the Test Serial Number, Test Start Date and 

Test End Date fields into the Support Contracts Custom Table. 

 

NOTE: This functionality currently works in the Act! desktop client only. 

 

To begin, browse to the Contact record that contains data you would like to migrate to a Custom 

Table, or create a lookup to perform this function for multiple records. 

 

Click Custom Tables > Data Import > Migrate from Contacts 
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Select the table where the records will be imported to from the list of Custom Tables. Using the 

radio button, select the Contacts in the database that will be used to perform the import, then click 

Next. 
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Map the required Act! Fields to the Custom Table Fields. Press Next twiceto begin the import 

process.  

 

At the end of the wizard click Finish. 

For each Contact, a new Custom Table record will be created and linked to that Contact. If we 

check the Support Contracts custom table, we can see the two new results at the bottom of the list 

and they have been linked to their Contact records correctly as well. 
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NOTE: The data in the original Act! fields has NOT been deleted. Once the customer has moved all 

of the data successfully, they might consider deleting those original fields since they will no longer 

need them (after taking a backup). 

 

Exercise 

Create 3 new standard fields in your Act! database, and call them Serial Number, Start Date and 

End Date. Make sure the first is a Character field, and the other two are Date fields. Populate these 

fields for contacts that you have not been working on so far. 

Use the Migrate process to pull the data for those contacts into your Support Contract Custom 

Table. 
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Sequential Fields  
 

This very useful feature of Custom Tables allows you to automatically populate a field with the next 

number in a sequence when creating a record. This functionality is also known as auto-numbering. 

In the example we have been using, this would be very helpful in automatically assigning a Support 

Ticket reference. Any new or existing Character type field can be made into a Sequential Field. In the 

example below, we will look at creating a new Sequential Field. 

 

Creating Sequential Fields 

To begin, click Custom Tables > Manage Custom Tables, then select a table from the Load Table 

dropdown. 

Under Field Management, either select an existing Character field and click Edit Field, or click 

Create Field to create a new one. 
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Progress through the field settings and enable the Sequential Field checkbox. 

 

Enter a Prefix or Suffix if required. 

Enter an Initial Value. Every time a new record is created, this will be incremented by 1. 

Select the Minimum Digits if the required number needs to be a certain length. 

For example: Using the prefix TICK_, with the Initial Value of 1 and Minimum Digits of 5 will give the 

value TICK_00001 on the first record. 
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Click Next twice then Finish. Make sure to add the Sequential Field as a column in your Custom 

Tables view. 

Sequential fields will begin numbering from the Next new record created. If you have existing 

records (such as Support Tickets), these will not automatically receive sequential numbers. 

If a customer has been using a field to manually enter a value (so let’s say they have been manually 

adding in Support Tickets with TICK_00001 etc.) then this will affect the Initial Value when they edit 

the field and make it into a Sequential Field. The customer would want to check the value that they 

were currently up to, then set the Initial Value to the next number in the sequence. That way 

whenever they create new Support Tickets, the values will be set and increase correctly 

 

Sequential Fields on Remote Databases 

Remote databases are unable to keep track of the current sequence of numbers in the main 

(publisher) database. For this reason, Sequential Fields in remote databases will be assigned a 
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random prefix to ensure they are not duplicates (NOTE: This is different to the prefix you can set 

when creating a field discussed above). These random prefixes can be changed by the remote user 

later. To do this: 

1. In the remote database click Custom Tables > Sequential Field Settings. 

2. A list of all sequential fields in the database will appear, allowing the random prefix to be 

changed. 

 

Exercise 

Create a Sequential Field for use within your Support Tickets Custom Table. 

Once created, add this field to your Layout and Default Columns. 

Add new Support Tickets into your database and test the sequential numbering. 
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Cascading Dropdowns  
 

Custom Tables includes an oft-requested feature which can significantly enhance the Act! 

experience. This feature is called Cascading Dropdowns.  

Cascading Dropdowns allow you to make the available values in a dropdown list depend on the 

value of another field. This functionality is also known as dependent dropdowns. 

Let’s take an example of recoding a Support Ticket. You may wish to create a dropdown to identify 

the product that the customer was calling about. Once the product has been selected, you may 

wish then to have another dropdown populate with the area of the program in the query, and make 

sure that the values available are specifically related to the product that was chosen. Finally, you 

could have yet another dropdown that will populate with the specific issues related to the area that 

was chosen. We will look at creating a similar example below. 

NOTE: This functionality currently works in the Act! desktop client only. 

 

Creating Cascading Dropdowns 

To begin creating a cascading dropdown, you must already have created dropdown fields in your 

Custom Tables section. These dropdowns need to contain ALL the possible values that will be 

used. The process below looks at setting up which values will cascade under which circumstances. 

For the purposes of our example, we have created the following dropdown character fields (all 

limited to list) with the values listed: 

Product 

- Act! Cloud 

- Act! Desktop 

Area 

- Contacts 

- Installation 

- Logging in 

- Web Browser 

Issue 

- Creating Contacts 

- Deleting Contacts 
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- Disk Space 

- SQL 

- Forgotten Password 

- Forgotten User Name 

- Incompatible Browser 

- Pop-up Blocker 

Now that these fields have been created, we can create the cascading rules. 

To begin, click Custom Tables > Manage Custom Tables, then select a table from the Load Table 

dropdown. 

Under Field Management, click Cascading Dropdowns. 

 

Click Add Cascading Dropdown. 
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Under Select source field select the field which the dropdown values will depend on. 

Under Select target field select the field the dropdown values will display in. Click Next. 
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Select a Source field value, then select whether to Display all values or Display selected values. 

If Display selected values is chosen, tick each of the values to display when the source field 

matches the selected value. 

Repeat the process for other source field values. In our example, Act! Cloud can display Contacts, 

Logging In and Web Browser, whereas Act! Desktop can display Contacts, Installation and 

Logging In. 

  

Click Next twice, then Finish once complete. 

Whilst that one level of cascading will be suitable for most customers, we are now going to add a 

further level of complication.  

Add another Cascading Dropdown, but this time we will use Area as the Source field, and we will 

use Issue as the Target field. 
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We will now set the following values: 

Contacts will display Creating Contacts and Deleting Contacts. 

Installation will display Disk Space and SQL. 

Logging In will display Forgotten Password and Forgotten User Name. 

Web Browser will display incompatible Browser and Pop-up Blocker. 
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We will now complete the rest of the wizard. As can be seen, two cascading dropdowns now exist 

in our table. 
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Working with Cascading Dropdowns 

To actually make use of the cascading dropdowns that we have created, we need to add our new 

fields to the Layout of the Custom Table. 

Do this by clicking Custom Tables > Manage Custom Tables, then from the Load Table 

dropdown, select an existing table. Finally click Design Layouts and choose the layout you want to 

edit. 

In the example below, the layout now shows the three dropdown fields we created earlier. 

 

Now if we create a new ticket, we will see the amended layout above, and we will be able to use our 

cascaded dropdowns correctly. 
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As you can see in the example above, all three dropdowns are cascading to each other correctly. 

 

Exercise 

Follow all the instructions under the subheading Creating Cascading Dropdowns above to 

thoroughly test this feature. 
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Field Security 
 

Field Security allows you to control access to individual Custom Tables fields by Act! user. This 

functions identically to the standard field level security feature in Act! and has the same potential 

benefits to the customer. 

NOTE: This functionality currently works in the Act! desktop client only. 

  

Setting Field Security 

To begin, click Custom Tables > Manage Custom Tables, then select a table from the Load Table 

dropdown. Click the field you wish to set field security for, then under Field Management, click 

Field Security. 

 

You will then be advised that the database needs to be locked to continue. 
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Once you have clicked Yes you will be presented with the Field Security screen. This works in 

exactly the same way as the standard Field Security screen already available within Act!. 
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Exercise 

Make sure you have created multiple users in your database. 

Choose a field in your Support Tickets Custom Table. Set access to Read Only for one user, and 

No Access for another. Log in with these users and test adding a new Support Ticket. 
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Advanced Query Editor  

The Advanced Query Editor provides a powerful way for you to search custom tables which have 

been added to the navigation stackbar. This functions in the same way as the standard Advanced 

Query Editor in Act!, but once the queries are created, they will appear at the top of the Custom 

Table once selected from the navigation stackbar. 

We will look at how to create a query below, then how to apply it to your Custom Table. 

NOTE: This functionality currently works in the Act! desktop client only. 

 

Creating an Advanced Query 

To begin, click the Lookup menu in Act!, then click Custom Tables and select a table. 
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Click Add, then select the Field Name, Operator and Value required, just as if you were creating a 

standard Advanced Query in Act!. In our example, we will look for any customers who have a 

Support Contract that expires this year (so the End Date is the Current Year). 

 

You can click Preview to show the results. 
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From here you can right click on the records to perform functions such as Merge To which we 

have already covered in this training, or you can click Go To if you want to jump straight to that area 

of the program. Effectively the Preview option is your actual results which you can begin working 

with. 

On top of that, you also have the ability to Save the query by clicking the Save button. When you do 

so, you are prompted to give the query a name. 

 

Saving a query is important for actually working with the advanced query as we can see below. 

 

Viewing a Saved Query 

Now that you have saved a query, you can quickly and easily use these when working within your 

Custom Table. To do so, select the Custom Table from the Navigation Stackbar. At the top of the 

screen there is a dropdown menu called Query. 
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The dropdown will show all of the advanced queries you have saved. To show the results, simply 

click the appropriate query in the dropdown list. 

 

Select All Records from the Query dropdown to return to the full list of records. 

 

Exercise 

Create an Advanced Query to find all of your Support Contracts that will expire in month of your 

choosing. 

Create an Advanced Query to find all of your Support Tickets that have been created on month of 

your choosing. 
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