Attention users of Act! v17 or older

If you are using an unsupported version of Act! (v17 or older), you are reminded that in accordance with the Act! Support Obsolescence Policy, you are no longer eligible to receive critical updates and enhancements that ensure your product continues to run optimally.

Important notice: We have recently been informed that an embedded third-party software component of Act! that facilitates licensing services is being discontinued by the manufacturer at the end of this year. As of January 1, 2019, certain common actions you may take that interact with the licensing component will cause Act! to fail and you will no longer be able to access your database. Examples of these common actions include attempting to install Act! on new hardware, modifying existing hardware, and modifying your user count. For an expanded list of actions, click here.

To ensure uninterrupted access to Act! in 2019, you must upgrade to the current version of Act! (v21) by December 31, 2018.

To soften the impact of this unexpected licensing development, Swiftpage has huge discounts on the first year of all Act! Premium Subscription products from November 6th through to December 31st, 2018. For more details on this promotion, please click HERE.

2018-11-05 23:15:22
 
Comments List